XSERVERでwp-cliを動かす方法

2016年5月1日日曜日
  • このエントリーをはてなブックマークに追加

とあるサイトをXSERVERに引っ越した。

せっかくなのでphp7でwordpressを動かしてみる。=>動いたので問題ない。

URLの変更とかパスの変更はwp-cliでやろうと思って、

参考URL: エックスサーバーに wp-cli を導入する

を試してみたけど、PHP5.3で動いているのでarray syntaxでエラーが出て動かなかった。

php5.4で動かしていたのでテーマとかプラグインのarray syntaxは[]に変えた。

調べると、/opt/php-7.0.3/に色々あったので、

alias 'wp=/opt/php-7.0.3/bin/php ~/bin/wp-cli'

にした。

ちなみに、/opt配下にその他のバージョンもあった。

php-5.4.13
php-5.4.25
php-5.4.26
php-5.4.35
php-5.4.45
php-5.5.0
php-5.5.10
php-5.5.19
php-5.5.30
php-5.5.9
php-5.6.15
php-5.6.18
php-7.0.0
php-7.0.3

今後バージョンアップしてもこの/optのパスに変えれば良さそう。

ラベル: ,


0 件のコメント:

コメントを投稿